Incident with updating information
Major incident
Here Comes the Bus
08-14-2025 09:09 AM CDT
· 4 months, 1 week, 7 hours
Updates
Resolved
December 19, 2025 · 03:09 PM CST
The Here Comes the Bus app has no active issues.
The Transportation Department is switching to the new app (StopFinder) and Here Comes the Bus will be deactivated by January 6.
Investigating
August 14, 2025 · 09:09 AM CDT
The Here Comes the Bus app is currently experiencing issues. This is a 3rd party app and the vendor is currently investigating.
← Back
Lewisville ISD Technology Status