Digital Instructional Resources Issue Confirmed

Major incident Digital Instructional Resources HMH - ED
08-15-2025 01:55 PM CDT · 3 days, 11 minutes

Updates

Resolved

Students are now able to access HMH Ed. THey may need to clear their website data and history in Settings app under Safari.

August 18, 2025 · 02:07 PM CDT
Investigating

Students may receive an error when logging in through the LHUB to HMH ED. HMH has been contacted to see what the issue is.

August 15, 2025 · 01:55 PM CDT

← Back