Digital Instructional Resource- Issue Confirmed

Major incident Digital Instructional Resources Perfection Next
08-20-2025 09:50 AM CDT · 1 day, 2 hours, 26 minutes

Updates

Resolved

Users can access Perfection Next again through the LHUB.

August 21, 2025 · 12:16 PM CDT
Investigating

Users trying to access Perfection Next for Handwriting are getting a SSO Login Error. We have reached out to the company asking why.

August 20, 2025 · 09:50 AM CDT

← Back