Digital Instructional Resource- Issue Confirmed

Major incident Digital Instructional Resources ParentLink
08-21-2025 11:19 AM CDT · 46 minutes

Updates

Resolved

Users should now be able to use Parentlink again through the LHUB.

August 21, 2025 · 12:04 PM CDT
Investigating

Users can not currently get into Parentlink through LHUB. Company has been notified and waiting for response.

August 21, 2025 · 11:19 AM CDT

← Back