Edgenuity Outage

Major incident Edgenuity
08-24-2020 10:18 AM CDT · 1 hour, 28 minutes

Updates

Resolved

Issues with Edgenuity are being reported as resolved.

November 4, 2021 · 10:24 AM CDT
Issue

Virtual students are unable to access Edgenuity and are receiving an error message.
Edgenuity is currently investigating errors in the Edgenuity courseware Students may not be able to access the Edgenuity platform

November 4, 2021 · 10:24 AM CDT

← Back