Emergency MDM maintenance

Major incident Self Service (MDM)
2020-09-02 10:55 CDT · 28 minutes, 25 seconds

Updates

Resolved

We believe this issue to be resolved. The MDM is back up and running.

September 2, 2020 · 11:24 AM CDT
Issue

The MDM is slow to respond to commands. We are performing emergency maintenance. ETA unknown.

September 2, 2020 · 10:56 AM CDT

← Back