Slow performance on YouTube, Google, and various sites

Minor incident Google
09-10-2025 08:00 AM CDT · 2 weeks, 7 hours, 53 minutes

Updates

Resolved

Issue has been resolved.

September 24, 2025 · 03:53 PM CDT
Issue

Content Keeper is investigating slow performance on YouTube, Google services, and other various websites. Several fixes have been implemented but the performance problem remains. They will continue to investigate a resolution.

September 17, 2025 · 09:38 AM CDT

← Back