Edgenuity is down for ES students and staff

Minor incident Edgenuity
2020-09-08 15:19 CDT · 2 hours, 52 minutes, 53 seconds

Updates

Resolved

According to Edgenuity’s status page this is now functioning normally.

September 8, 2020 · 06:12 PM CDT
Investigating

Edgenuity is down for ES students and staff

September 8, 2020 · 03:20 PM CDT

← Back