Digital Instructional Resources Issue confirmed

Major incident Digital Instructional Resources ParentLink
10-05-2025 04:19 PM CDT · 15 hours, 10 minutes

Updates

Resolved

Users can now access Parentlink thru LHUB/ClassLink.

October 6, 2025 · 07:30 AM CDT
Update

Finalsite is performing emergency maintenance on their system. We are hoping that it will be functioning on Monday.

October 5, 2025 · 05:31 PM CDT
Investigating

Accessing Parentlink through ClassLink is currently not working for users. We have reached out to Finalsite to find out why.

October 5, 2025 · 04:19 PM CDT

← Back