Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources ParentLink
10-06-2025 09:39 AM CDT · 1 day, 21 hours, 55 minutes

Updates

Resolved

Parentlink is now operational again. Finalsite has restored all of the accounts.

October 8, 2025 · 07:34 AM CDT
Issue

Parentlink is down again for users when going through LHUB. Finalsite is still dealing with an Emergency Maintenance issue.

October 6, 2025 · 09:39 AM CDT

← Back