Google Drive - Service disruption

Minor incident Infrastructure Internet
09-15-2020 10:48 AM CDT · 44 minutes

Updates

Resolved

9/15/20, 11:17 AM

The problem with Google Drive should be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Google, and we are making continuous improvements to make our systems better.

November 4, 2021 · 10:24 AM CDT
Investigating

9/15/20, 10:10 AM

Google continuing to investigate this issue. We will provide an update by 9/15/20, 11:10 AM detailing when we expect to resolve the problem. The affected users are unable to access Google Drive.

9/15/20, 9:29 AM

Google investigating reports of an issue with Google Drive. We will provide more information shortly. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

November 4, 2021 · 10:24 AM CDT

← Back