Edgenuity issues with submission requests

Minor incident Edgenuity
2020-09-16 08:59 CDT · 2 hours, 23 minutes, 45 seconds

Updates

Resolved

Edgenuity reports the issues have been resolved.

September 16, 2020 · 11:23 AM CDT
Issue

Edgenuity is aware of the old submission requests that are taking place in content areas. Most are reporting in ELA and Art. This could effect other areas and we are working to get this resolved.

September 16, 2020 · 09:03 AM CDT

← Back