Intermitent issues accessing internet websites and services.

Major incident Infrastructure Internet
10-14-2025 08:00 AM CDT · 1 day, 45 minutes

Updates

Resolved

Issue seems to be resolved.

October 15, 2025 · 08:45 AM CDT
Monitoring

Issue seems to be resolved.

October 15, 2025 · 08:44 AM CDT
Monitoring

The internet connectivity issues appear to be resolved. We will continue to monitor performance.

October 14, 2025 · 02:13 PM CDT
Issue

LISD Technology has identified an upstream issue at Region 11 that is effecting internet access. LISD will be transitioning to our backup ISP shortly.

October 14, 2025 · 01:24 PM CDT

← Back