Various sites and services unavailable due to Amazon AWS outage

Major incident Canvas Classlink SSO Eduphoria Frontline Absence Management (Sub System) Incident IQ (http://support.lisd.net) Insignia Library Learning Hub Webex Yuja Video Platform
10-20-2025 06:00 AM CDT · 1 day, 1 hour, 35 minutes

Updates

Resolved

Amazon has resolved the issues with AWS.

October 21, 2025 · 07:35 AM CDT
Update

Adding Eduphoria to impacted services.

October 20, 2025 · 09:20 AM CDT
Issue

Amazon AWS platform is experiencing an outage and is impacting several LISD sites and services. ClassLink/LHub is offline and any services authenticated through that service are inaccessible no matter where they are hosted(Incident IQ).

You can learn more about the Amazon outage on their status page at: https://health.aws.amazon.com/health/status

October 20, 2025 · 04:30 AM CDT

← Back