Digital Instructional Resources- Issue Confirmed

Minor incident Digital Instructional Resources Savvas Realize
10-23-2025 03:11 PM CDT · 18 hours, 16 minutes

Updates

Resolved

It seems that SAvvas has fixed the issue from yesterday. If something is still not right, submit a help ticket.

October 24, 2025 · 09:28 AM CDT
Issue

Users can get into Savvas, but may find that accounts are not working correctly, or classes are not active. Savvas knows about it and is working on a solution. It is tied to the issue they had earlier.

October 23, 2025 · 03:11 PM CDT

← Back