Raptor offline

Major incident Raptor
10-29-2025 11:13 AM CDT · 1 day, 1 hour, 42 minutes

Updates

Resolved

Raptor has resolved this issue. Raptor is now functioning.

October 30, 2025 · 12:54 PM CDT
Issue

The Raptor website is not responding. Technology is working with Raptor support to resolve the issue.

October 29, 2025 · 11:13 AM CDT

← Back