Digital Instructional Resource- Issue confirmed
Major incident
Digital Instructional Resources
ICEV
Mindplay
10-29-2025 01:17 PM CDT
· 2 hours, 23 minutes
Updates
Resolved
October 29, 2025 · 03:40 PM CDT
Mindplay and iCEV are now accessible. The issue with Microsoft has been fixed.
Issue
October 29, 2025 · 01:17 PM CDT
For those users that use Mindplay and iCEV, both are currently down do to a Microsoft Azure and AWS issue. Both companies are working to restore.
← Back
Lewisville ISD Technology Status