Incident IQ Tickets Not Loading
Major incident
Incident IQ (http://support.lisd.net)
10-30-2025 12:51 PM CDT
· 3 hours, 30 minutes
Updates
Resolved
October 30, 2025 · 04:12 PM CDT
Incident IQ has reported that the issue is resolved and are continuing to monitor the situation. For more detail please refer to the Incident IQ Status Page.
Issue
October 30, 2025 · 12:51 PM CDT
Incident IQ has confirmed an issue affecting the loading of tickets. They are currently investigating. Please refer to Incident IQ status page for more information.
← Back
Lewisville ISD Technology Status