Microsoft 365 is experiencing login and authentication issues

Minor incident Office 365 / Staff Email
2020-09-28 18:45 CDT · 12 hours, 44 minutes, 6 seconds

Updates

Resolved

Microsoft has resolved their authentication issues.

September 29, 2020 · 07:29 AM CDT
Issue

Microsoft is experiencing login and authentication issues. More information is available on Microsoft’s health status dashboard

September 28, 2020 · 06:47 PM CDT

← Back