Digital Instructional Resource issue confirmed
Minor incident
Digital Instructional Resources
i-Ready
11-03-2025 02:12 PM CST
· 1 day, 17 hours, 20 minutes
Updates
Resolved
November 5, 2025 · 07:31 AM CST
I-Ready has fixed the issues they were having. Should be functioning normal now.
Issue
November 3, 2025 · 02:12 PM CST
i-Ready is experiencing degraded performance. We have seen where students are getting logged out multiple times. i-Ready is working on a solution.
← Back
Lewisville ISD Technology Status