Digital Instructional Resource Issue confirmed
Minor incident
Digital Instructional Resources
i-Ready
11-12-2025 11:33 AM CST
· 2 hours, 34 minutes
Updates
Resolved
November 12, 2025 · 02:06 PM CST
i-Ready says they corrected the issue. For the rest of the day only they have temporarily disabled real-time reporting. Please be assured that no data has been lost and all reporting will be updated and restored after tonight’s nightly sync.
Issue
November 12, 2025 · 11:33 AM CST
i-Ready is experiencing degraded performance and are investigating. This will possibly affect the function of i-ready for users.
← Back
Lewisville ISD Technology Status