ClassLink sign in issues

Minor incident Classlink SSO
2020-10-06 08:54 CDT · 3 hours, 1 minute, 26 seconds

Updates

Resolved

The issue appears resolved.

October 6, 2020 · 11:56 AM CDT
Issue

ClassLink is experiencing issues with their authentication systems. More information is available here: https://status.classlink.com/

October 6, 2020 · 08:55 AM CDT

← Back