Digital Instructional Resources Issue confirmed
Major incident
Digital Instructional Resources
Savvas Realize
12-03-2025 12:26 PM CST
· 38 minutes
Updates
Resolved
December 3, 2025 · 01:04 PM CST
Savvas has had the issue fixed. Users should be able to log in now.
Issue
December 3, 2025 · 12:26 PM CST
Savvas has posted to their status page that they are experiencing performance issues and users may not be able to log on.
← Back
Lewisville ISD Technology Status