Error accessing Skyward
Major incident
Skyward SIS
01-05-2026 09:26 PM CST
· 15 minutes
Updates
Resolved
January 5, 2026 · 09:41 PM CST
Issue resolved. Users should be able to access via the Skyward app, as well as through the browser.
Investigating
January 5, 2026 · 09:26 PM CST
It has been reported that users are receiving an error message when trying to access Skyward through the Skyward app, as well as through a browser. The LISD team is in communication with Skyward.
← Back
Lewisville ISD Technology Status