Skyward SMS Server/Login Issues

Major incident Skyward SIS
01-19-2026 09:13 PM CST · 10 hours, 46 minutes

Updates

Resolved

Issue resolved.

January 20, 2026 · 07:59 AM CST
Monitoring

Vendor support reports server issues resolved. Confirmed users able to access and log into system now. LISD Technology will continue to monitor.

January 19, 2026 · 09:23 PM CST
Issue

Users experiencing issues trying to log into Skyward SIS. Mix of “WebSpeed” errors and “HTT” error messages. Vendor support has been contacted.

January 19, 2026 · 09:13 PM CST

← Back