Eduphoria Aware

Minor incident Eduphoria
03-13-2026 09:00 AM CDT · 1 week, 5 days, 5 hours, 9 minutes

Updates

Resolved

This issue has been resolved.

March 25, 2026 · 02:10 PM CDT
Issue

Eduphoria is receiving reports of sporadic loading and server errors within Aware and other Eduphoria applications for some users. Eduphoria is currently investigating the issue.

March 13, 2026 · 09:00 AM CDT

← Back