Edgenuity LMS Errors

Major incident Edgenuity
12-07-2020 12:49 PM CDT · 2 hours, 20 minutes

Updates

Resolved

Edgenuity is reporting this issue as resolved.

November 4, 2021 · 10:24 AM CDT
Monitoring

Edgenuity is reporting a fix has been implemented and they are monitoring the results.

November 4, 2021 · 10:24 AM CDT
Investigating

Edgenuity is currently looking into reports of unexpected errors with their Teacher and Student LMS. Edgenuity is currently investigating this issue.

November 4, 2021 · 10:24 AM CDT

← Back