Intermittent internet issues

Major incident Infrastructure Internet
2020-12-10 13:19 CDT · 23 minutes, 29 seconds

Updates

Resolved

The network team believes the issues has been resolved.

December 10, 2020 · 01:43 PM CDT
Issue

The network team is investigating issues with websites and internet resources failing to load.

December 10, 2020 · 01:21 PM CDT

← Back