Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
2019-08-13 12:46 CDT · 20 minutes, 43 seconds

Updates

Resolved

Service is back up.

August 13, 2019 · 01:07 PM CDT
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

August 13, 2019 · 12:46 PM CDT

← Back