Digital Instructional Resource- Issue confirmed

Major incident Digital Instructional Resources Savvas Realize
06-29-2026 09:30 AM CDT · 1 hour, 47 minutes

Updates

Resolved

Users can now access Savvas through Classlink.

June 29, 2026 · 11:18 AM CDT
Investigating

Users trying to access Savvas through Classlink will get an error message and not be able to. Savvas is investigating the issue.

June 29, 2026 · 09:30 AM CDT

← Back