Chromebook Logins not functioning

Major incident Classlink SSO
2019-08-19 13:50 CDT · 17 hours, 40 minutes, 24 seconds

Updates

Resolved

Google resolved the issue. Technology has confirmed Chromebook logins are working.

August 20, 2019 · 07:30 AM CDT
Issue

We’ve confirmed Google logins are failing on Chromebooks. Other Google customers are reporting the similar issues. We’ll update when we learn more information.

August 19, 2019 · 01:52 PM CDT

← Back