Google Workspace Login Issues

Minor incident Google
07-20-2026 07:44 AM CDT · 3 days, 5 hours, 28 minutes

Updates

Resolved

There have been no additional reports of this incident since the fix was implemented. Marking as resolved.

July 23, 2026 · 01:11 PM CDT
Update

A fix has been implemented and we are continuing to monitor.

July 20, 2026 · 10:07 AM CDT
Investigating

Users are reporting they are receiving an error that their email address isn’t recognized when attempting to sign into Google. We are currently investigating the issue.

July 20, 2026 · 07:44 AM CDT

← Back