Incident IQ is slow and may fail to create/update tickets

Minor incident Incident IQ (http://support.lisd.net)
08-11-2026 01:11 PM CDT · 45 minutes

Updates

Resolved

IIQ support has resolved the issue.

August 11, 2026 · 01:57 PM CDT
Issue

Incident IQ is experiencing an issue with their cloud platform that is causing slow page loads and failures when creating or updating tickets. You can track the status of Incident IQ’s problem here: https://status.incidentiq.com/incidents/9t55d971j2qq[https://status.incidentiq.com/incidents/9t55d971j2qq](https://status.incidentiq.com/incidents/9t55d971j2qq)

August 11, 2026 · 01:11 PM CDT

← Back