Knowledge Hub (KHUB) is down Internally

Major incident Knowledge Hub (KHUB)
08-12-2026 07:54 AM CDT · 3 hours, 26 minutes

Updates

Resolved

KHUB is now functioning internally and externally.

August 12, 2026 · 11:20 AM CDT
Investigating

Internal articles for KHUB are not accessible at the moment. Only external articles are by going to khub.lisd.net. The vendor is looking into the issue.

August 12, 2026 · 07:54 AM CDT

← Back