OneScreen account logins are failing
Major incident
OneScreen Interactive Flat Panels
08-14-2026 08:02 AM CDT
· 2 days, 6 hours, 53 minutes
Updates
Monitoring
August 14, 2026 · 12:59 PM CDT
OneScreen Support has implemented a fix. Account logins are functioning on our test board. Please try to sign in and update any support tickets with your results.
Issue
August 14, 2026 · 08:02 AM CDT
OneScreen account logins are failing with the message “No network”. There seems to be an issue with OneScreen’s account servers as we are able to reproduce this issue off the LISD network. The guest account should be functional in the meantime.
← Back
Lewisville ISD Technology Status