Slow load times or errors when accessing New Quizzes in Canvas

Minor incident Canvas
09-03-2026 10:05 AM CDT · 1 hour, 16 minutes

Updates

Resolved

The issue was identified. A fix has been implemented. The quizzes are now working correctly.

September 3, 2026 · 11:20 AM CDT
Issue

Some users are experiencing slow load times and page errors when accessing New Quizzes. Instructure has posted an outage on their status page. For more information see: https://status.instructure.com/

September 3, 2026 · 10:22 AM CDT

← Back