Eduphoria Loading

Minor incident Eduphoria
09-10-2026 09:34 AM CDT · 1 hour, 49 minutes

Updates

Resolved

Issue has been resolved.

September 10, 2026 · 11:23 AM CDT
Issue

Eduphoria is experiencing long loading times and is failing to load modules. This is an issue with Eduphoria itself and they are investigating.

September 10, 2026 · 09:34 AM CDT

← Back