Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
08-31-2019 02:57 AM CDT · 21 minutes

Updates

Resolved

Service is back up.

August 31, 2019 · 03:18 AM CDT
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

August 31, 2019 · 02:57 AM CDT

← Back