Slowness Reported in Skyward

Minor incident Skyward
17 hours, 11 minutes, 33 seconds

Updates

Resolved

Skyward is functioning normally at this time. :)

September 5, 2019 · 08:03 CST
Investigating

There has been sever slowness reported in Skyward. A ticket has been created with them and we are awaiting a response.

September 4, 2019 · 14:53 CST

← Back