Canvas errors

Major incident Canvas
2021-03-03 15:36 CDT · 57 minutes, 6 seconds

Updates

Resolved

Canvas has resolved the issue.

March 3, 2021 · 04:33 PM CDT
Issue

Canvas is reporting errors loading pages. Their support is investigating the issue. Further information may be available at https://status.instructure.com/

March 3, 2021 · 03:37 PM CDT

← Back