Munis application is currently having unexpected issues

Major incident Munis / Employee Self Service
03-05-2021 10:00 AM CDT · 1 hour, 30 minutes

Updates

Resolved

The Munis application issues have been resolved

November 4, 2021 · 10:25 AM CDT
Issue

The Munis application is having unexpected issues and we are working on the problem

November 4, 2021 · 10:25 AM CDT

← Back