Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
7 minutes, 2 seconds

Updates

Resolved

Service is back up.

September 9, 2019 · 19:17 CDT
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 9, 2019 · 19:10 CDT