Difficulty accessing or slowness within the Savvas Realize program

Major incident Digital Instructional Resources Pearson (SAVVAS)
2021-03-09 10:26 CDT · 5 hours, 47 minutes, 22 seconds

Updates

Resolved

Pearson reports the issues are resolved.

March 9, 2021 · 04:13 PM CDT
Investigating

Pearson reports the issues are resolved.

March 9, 2021 · 04:13 PM CDT
Issue

We’ve received reports of difficulty accessing or slowness within the Savvas Realize program. Pearson support is aware of the problem are working on a resolution.

March 9, 2021 · 10:28 AM CDT

← Back