Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
2019-09-12 00:11 CDT · 12 minutes, 5 seconds

Updates

Resolved

Service is back up.

September 12, 2019 · 12:23 AM CDT
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 12, 2019 · 12:11 AM CDT

← Back