MUNIS is unavailable due to technical issues.

Major incident Munis / Employee Self Service
03-23-2021 11:21 AM CDT · 1 hour, 14 minutes

Updates

Resolved

The issue has been resolved.

November 4, 2021 · 10:25 AM CDT
Issue

The Technology team is troubleshooting the issue.

November 4, 2021 · 10:25 AM CDT

← Back