Raptor Login Issues

Minor incident Raptor
2021-03-24 15:30 CDT · 1 day, 19 minutes, 46 seconds

Updates

Resolved

Raptor login issues have been fixed. Try clearing your browser cache and restarting your browser if you still experience login issues.

March 25, 2021 · 03:49 PM CDT
Issue

Raptor is currently experiencing login issue. Some users are unable to sign into Raptor at this time. The Technology department has contacted Raptor support and the issue is being investigated.

March 24, 2021 · 03:33 PM CDT

← Back