Canvas failing to load

Major incident Canvas
2021-03-25 07:46 CDT · 1 hour, 30 minutes, 8 seconds

Updates

Resolved

The canvas issues appear to be resolved.

March 25, 2021 · 09:16 AM CDT
Issue

The Canvas website is failing to load.

March 25, 2021 · 07:48 AM CDT

← Back