Service Technology Help Portal (LiveTime http://support.lisd.net) seems to be down

Major incident Technology Help Portal (http://support.lisd.net)
2019-09-18 13:27 CDT · 28 minutes, 19 seconds

Updates

Resolved

Service is back up.

September 18, 2019 · 01:55 PM CDT
Issue

Our monitoring system has found out the service Technology Help Portal (LiveTime http://support.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 18, 2019 · 01:27 PM CDT

← Back