Service Munis seems to be down

Major Incident Munis
58 minutes

Update

Resolved

Service is back up.

Sep 19th, 2019 17:30 CDT
Issue

Our monitoring system has found out the service Munis is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Sep 19th, 2019 16:33 CDT