Google Service Disruption

Major incident Google
2021-04-12 08:41 CDT · 3 hours, 8 minutes, 34 seconds

Updates

Resolved

Google is reporting the service issues with Drive, Docs, Sheets, Slides, and Classroom are resolved as of 11:20am.

https://www.google.com/appsstatus#hl=en&v=status

April 12, 2021 · 11:50 AM CDT
Update

Google has changed the status from a Service Disruption to an Outage.

https://www.google.com/appsstatus#hl=en&v=status

April 12, 2021 · 10:18 AM CDT
Issue

Google is experiencing service disruptions with the following applications:

Drive, Docs, Sheets, Slides, and Classroom

https://www.google.com/appsstatus#hl=en&v=status

April 12, 2021 · 08:45 AM CDT

← Back